News | Forum | People | FAQ | Links | Search | Register | Log in
Q1SP - The Hand That Feeds You
OK, here is my new map, posted on, mirrored at mediafire:

Here are some screenshots, same arrangement:

Heres the MapSource, same arrangement:

And finally a skill 2 demo with spoilers:

This map requires QUOTH. Also, please use an engine with lit file support, i.e. FitzQuake (Recommended), JoeQuake or Darkplaces!

Quite a big map, primarily idbase, there are 306 monsters on hard!

Thanks to all those who helped!

Happy Christmas!

[Edited out zipped screenshots, wtf]
First | Previous | Next | Last
"Just A Quake Pack" 
Have you forgotten how many monsters you put in?? ;)

There's nothing "just a ..." about it! 
I like WarpSpasm. I mean I like skill2. I was playing Warpd last night on skill2. Very hard. Kept running out of ammo. I guess you need to find the secrets. Also, I guess you need to make your ammo count. If I wanted to have an easier time I would play skill 1, but it kinda takes the challenge out really, doesnt it?

FYI I go 220-odd monsters in, and gave up.

Doesnt mean I'm not gonna try again tho. It means that I AM!! :-D 
I realised after release that warpd just wasn't finished enough and that I should have been alot more generous on the ammo, and details. It was basically me and Sielwolf playtesting it - he almost never puts a foot wrong even on the most difficult maps and I knew where everything was.

For warpd ammo-wise you should try and cause as many enemies as possible to leap into the void, find as many secrets as you can (there's a practically invisible one near the second silver key / above the two vores) and snatch every single enforcer backpack for the plasmagun. Also, make sure to switch between weapons a fair bit to try and balence against the ammo that you're finding.

That's the kind of underhanded tactics I was balancing for - I also managed to beat Xaero on nightmare just by taking advantage of the bad AI. And I've sent that fucking gnome from episode 2 into outer space:

But I didn't get the achievement - got a load of screenshots but my Steam id didn't update to include "Little Rocket Man". Fuckers. 
Oh Yeah 
And warpd has 666 monsters on hard. It was interesting working within a set limit of enemies. I'm not advocating filling the map just for the sake of it, but maybe as a speed or turtle mapping event it could be good - ~10 monsters only, for example. 
You probably would have had a hard time finding playtesters for the whole thing. 
I Pretty Much Retreated To A Cave 
Sending out the odd email or beta update as time passed, building the thing. I was using every spare minute to map - lunchtimes, after work, at home, weekends etc.

I had a good base to work from with aguirRe and Sielwolf - both experts in what they do in the Quake sphere.

A wider playtesting base would have helped, but the volume of mapping there made it a daunting prospect. 
I like Sielwolf, but he's frighteningly good at Quake. I mean I dont really want to look the gift-horse in the mouth here, but if he say that the map is a "nice challenge" it probably means that most people would find it "far to tough"

Hehe - he has posted demos of Warpd in the WARP thread, right?

We should really move this discussion there... 
Sorry for being an ass, could you please upload both sickbase demos to the shub-hub, I lost them myself (serves me right I guess).

Thanks for the kind words :() dunno what else to say. 
Played this.

Numerous nice things!
The FPS was a bit low in the room that had lots of lava down and had that spinning yellow circle thing. Pretty near end.

There were lots of varied architecture things with details and it wasn't the same throughout, and I liked how the light made it feel so different inside and outside. And I didn't get so badly lost as with many maps. Either. The bridge button could have been a bit more obvious perhaps.

I also loved the end how it was so "sense of awe" that you could actually break outside.

I made a demo too, first play, skill 1: 
Been playing this today and come across an error, which I've recieved a few times. Pretty far into the map when you step onto the 'teleporter', it'll blow up but then FitzQuake will hang, then quit the map. The following error is then displayed in the console:

Host_Error: Program Error 
OK, Dont Know... 
...I've never had that one before!

Erm, I always tested in Fitz too! OK, so what operating system are you using? Cause if it's not windows then I wouldnt know.

The only really obvious thing I can think of is are you playing through Quoth? Some people didnt realise this was a Quoth map before and had problems (but not like the one you've described).

Maybe its an error between Quoth1 and Quoth2.

It could work in Quoth1 but not Quoth2, although I would assume otherwise, cause they assure us Quoth2 is backward compatible.

Anybody got a clue? 
Yeah, I'm running under Windows, and using Quoth 2. 
OK, Right - No Problem.... 
...well I just tried it in windows with Quoth2 and had the same bug!!

Preach ?!?!?

Temp Solution - Re-install Quoth1 and play under that. You'll have to make a new folder in your Quake directory called "Quoth1" or something, then run fitz with "-game quoth1"

That should fix the problem, but it's a temporary fix...

Thanks For Playing Though.... 
...and thanks for reporting this bug! :) 
I've figured out what's causing this bug - code that's designed to kill the player off when using the coop bomb is also shared by the info_bomb when it shouldn't be. I can't fix this right now as I'm away from the computer with the quoth source code. A patch for this problem will be issued later - which will also sort out the earthquake warnings. For now, to downgrade to quoth1 you don't even need to reistall to a new directory - you can rename pak1.pak temporarily to revert the change that causes the crash. 
Thanks Preach ! 
BTW: There also seems to be an incompatibility issue between Quoth1 and Quoth2 concerning the trigger code. I have a setup including info_notnull hacks (InitTrigger/multi_trigger) for a monster to fire which work in Quoth but are broken in 2. Though I'll have to investigate this further to pinpoint the exact cause. 
Now this is odd, unless I'm doing something wrong on my side...

I moved the PAK1 for Quoth2 out of the way so it's not found in the same folder. Upon loading my last save game I get the following console error:

Host_Error: ED_ParseEdict: parse error

And upon starting a new game by loading the map in the console, all of the monster respawns have already been triggered. 
You Might 
get a more informative error meesage using my engines. In any case, savegames might not be compatible even between two minor versions of the same progs, let alone two major ones.

This is just one of the prices for mixing up Quoth1/Quoth2 in the same directory. 
This is my first post here.
I've just played your thehand map. At least until the very end when I ran in the same problem like Quakis.
The setup : WinXP, JoeQuake , The Quoth folder where you said in readme to put the map files, the pak0 from Quoth1 and pak1 from Quoth2 (i supposed pak1 would come along with pak0, not in separate folder!!).
I loaded the savegame before the crash in darkplaces and fitzquake 0.8 and the same problem, it freezes a few seconds after touching the unstable slipgate. The only remarkable difference is that the screen doesnt shake in joequake at those quake moments.

Looks like i have to remove the pak1 also and play again, or noclip directly to that part of map and see what happens next :)

I was playing it in glorious 1280x1024, all eye candy on (excepting detailed textures that doesnt look that good for me), using lastest version of joequake (that loads directly the skybox), the coloured lighting is at its places, all ok. Man, i want to say that for me your map is not only big and interesting, but awesome in visual appareance, I liked it very much. In fact got excited in many moments :D
It remembers me of many newer games. The skybox and coloured lighting has their credits here (and too for their creators, Quoth's also).

Would it be awesome to make an episode of such beautiful maps... :P
Yes, I know, lots of work required :( 
Quoth 1 
I encountered the same bug while playing this map. Does anybody know where I could get just Quotj 1 to play through this? 
This Should Be Quoth1, But I Am Not Sure 
I think if you install quoth2 then remove all of the pak files except for pak0 then it may work...... (hopefully) 
No, I tried that. Gives a Parse error. 
This was patched in quoth 2.1, make sure you have the latest version - with a pak2 as well as a pak1. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.