News | Forum | People | FAQ | Links | Search | Register | Log in
Fitzquake 0.80 Released (finally!)
New in this version: map loading is 4x faster, you can change video modes without restarting, cvar control of anistropic filtering, refresh rate, and vsync, cvar control of max_edicts, r_showtris support, and a typical long list of bugfixes and optimizations.

Go! http://www.celephais.net/fitzquake
First | Previous | Next | Last
:) 
finally indeed!
congrats, slime :> 
Finally! 
ahh, showtris! i'd almost given up hope on this... a lot of the other features will come in handy, too. thanks :) 
Metlslime 
AAAAAAaaaaahhhhhhh !!! This is the good news of the day ! Thanx !! 
:) 
i use tremor but is always good to people still update there engines! good work! 
Awesome 
Very cool. I'm a relatively new quake player and i love your engine, it's my favorite, so it's great to see a new version come out. I like how you fixed the glitch, at least for my computers, that would cause the details to disappear from all ceiling or floor textures when i would look straight up or down. It was never a big deal, but it's nice to see it fixed. 
Metl 
4x faster, this engine was already one of the quickest loaders around??

Also, those vsync, refresh rate options are excellent. More games (and engines) should let you control that individually.

2 questions : Does anistropic filtering actually do much on the quake textures? And how about that model interpolation (I know, I know I'm a broken record)? 
Argh! 
Damn, why metlslime, why?
Heh, I'm back to Windows then...

A new Fitzquake is more than just a reason, Fitzquake is just the best engine around in my opinion. Although there are many very useful functions added, it is still one of the most faithful engines around.
On the one hand I hate you for releasing a new version, on the other hand I love you for it. Seems like the other hand is much bigger, since it just squashed my will to stay entirely with Linux. Gonna install Windows again now! 
A Second That Broken Record 
model interpolation, click ...........
model interpolation, click ...........
model interpolation, click ...........
model interpolation, click ........... 
Great! 
No SM69 to accompany the new Fitz? 
Gl_texture_anisotropy Is Very Welcome 
Having to force settings through the control panel in order to get what my video card is capable of giving for old games is such a pain in the ass (and then I have to turn them back off to play modern titles at a decent framerate).

The other features are also good. FitzQuake for President! 
Nitin: 
anisotropic filtering: yes, i think it's visibly better.

model interpolation: in the next version, hopefully. 
Also: 
as for the faster loading, this was motivated by the fact that 0.75 loaded slower than previous versions. I optimized it back down to being almost as fast as glquake for 0.80.

Thanks for the kind words, everyone. 
Ooooh 
i look forward to testing this baby out when I get home. Congrats metlslime on seeing your baby develop, I'm sure it must feel great. 
Metl 
The new r_showbboxes cvar is very useful, but it doesn't always seem to have the right position around the entity. Is this intentional? 
Aguirre: 
i believe the positioning is correct. If you noticed the off-center bboxes on ammo pickups, it's becuase small boxes are 24 on a side instead of 32, but the quakec shifts all ammo bmodel origins by 16 regardless of size.

It's also possible there's a bug. What are you seeing that seems wrong? 
I Was Only 
checking briefly in a map that I've could have used this feature a few days ago; the big soe2m5 from Tronyn's SoE pak. Using this new cvar, I could see that several ammo/health boxes were not inside the outlined bbox.

Some of them were partly inside walls and some were rather close to each other. Maybe this is actually an explanation for why I sometimes have problems picking up ammo/health boxes.

It appears as if they are slightly beside the visible object, so I have to move partly inside it to make the engine notice the collision and pick up the object.

Using this cvar, I could also verify the poor Scrag that lived its whole life inside a solid rock ... ;) 
Oh Shit Oh Shit!! 
cvar control of max_edicts

BOOJAH! 
Cvar Control Of Max_edicts 
SPOOGE!!!! ....click
SPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....click


SPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....click
SPOOGE!!!! ....click
SPOOGE!!!! ....clickSPOOGE!!!! ....click
SPOOGE!!!! ....click
SPOOGE!!!! ....clickv



SPOOGE!!!! ....clickSPOOGE!!!! ....clickSPOOGE!!!! ....click 
OMG 
You bastard! 
Pak Problems 
With 0.75 I got an edicts error on e3m4 and it runs now but there's an artifact around the start. I suspect my pak1.pak is corrupted. Can anyone verify the md5sum for me? I get:
aa40edd55098bbb21692597fdc2533fa *PAK1.PAK 
Potential Problem Found 
When switching from .75 to .80, if the commandline -dinput is used, the mouse becomes a dead weight. I use WinXP so -dinput is a must because XP doesn't let you disable mouse acceleration. I kind of view this as a serious bug, but if it was intentionally removed, I'll have to stay with .75 I guess. 
Kickstand 
Try downloading this and addind it to your windows registry, works for some people:

http://ftp.thecpl.com/mouse_fix.zip

(Here's the page where I found it just now: http://members.cox.net/keithkman/xpmousefix.html )

You can also try adding -noforcemaccel -noforcemparms to your quake shortcuts. 
Kickstand: 
not intentional, and in fact i never used -dinput so i didn't know what it did. I use XP and I have mouce acceleration disabled, but it's globally disabled so maybe you're saying it can't be disabled per app.

I've done research into the winAPI calls to control mouse accelleration, and i was planning on adding some sort of cvar control eventually. But i didn't know about all those command line swiches that you and frib mention, so maybe there's enough customizability already present.

Anyway, i'll investigate your bug, too. 
Metl 
-dinput drastically reduces your mouse sensitivity in FQ 0.8... but this behaviour is the same as previous versions of Quake when I've tried -dinput (winquake, glquake, etc), so I don't think you've broken anything.

I've not tried -dinput in FQ 0.75 tho 
Metl 
I get this error when loading a particular testmap from a batch file:

http://www.lunaran.com/pics/fitzerror1.png

Loading fitzquake normally and then loading the map doesn't prompt the error, nor does loading a different map from the batch file.

I can send you the .bsp if you need to test it. I have no idea why it's special but I've never gotten this error before with previous fitzquakes. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.