News | Forum | People | FAQ | Links | Search | Register | Log in
Worldcraft 1.6A, Quake 1 Mapping
A thread to help us lesser map makers
First | Previous | Next | Last
When Worlds Collide...Win XP And Worldcraft Meet 
I am having a lot of trouble getting Worldcraft v1.6a to work properly with Windows XP. I did not have these types of problems when running Worldcraft on Windows 98. The problems generally result when trying to compile a map.

Here is an error that I am currently getting:

A window pops up after attempting to run the map:
�The file C:\QUAKE\ID1\maps\Test1e was not built, do you want to continue�
When I click �Yes� I get a new window with the following error:

�The command failed. Windows reported the error: �Invalid Argument� Do you want to continue?�

So I click Yes again and I get the following Error:
Quake Error: �W_LoadWadFile: couldn�t load gfx.wad�


A separate �Process Window� is also open from the time of the first error message and the following is diplayed:

** Executing...
** Command: C:\wc\Q1Tools\LIGHT.EXE
** Parameters: C:\QUAKE\ID1\maps\Test1e

----- LightFaces ----
************ ERROR ************
Error opening C:\QUAKE\ID1\maps\Test1e.bsp: No such file or directory

** Executing...
** Command: C:\wc\Q1Tools\Vis.exe
** Parameters: C:\QUAKE\ID1\maps\Test1e

---- vis ----
************ ERROR ************
Error opening C:\QUAKE\ID1\maps\Test1e.bsp: No such file or directory

** Executing...
** Command: Change Directory
** Parameters: c:\quake\winquake.exe

The command failed. Windows reported the error:
"Invalid argument"

** Executing...
** Command: C:\QUAKE\winquake.exe
** Parameters: +map Test1e

** Executing...
** Command: Copy File
** Parameters: "C:\QUAKE\OURMAP~1\" "C:\QUAKE\ID1\maps\"

** Executing...
** Command: C:\wc\Q1Tools\QBSP.EXE
** Parameters: C:\QUAKE\ID1\maps\Test1e

outputfile: C:\QUAKE\ID1\maps\Test1e.bsp
************ ERROR ************
Token too large on line 3

Can anyone offer some help with this problem and get me back on track with my map making hobby?

I am most grateful

I would also be grateful to learn if anyone is using a better editor for making Quake 1 maps, or if they have a program(s) that can compile and/or decompile maps. 
Looks Outa Sequence And Too Many .wads 
If that's the sequence that actions are taking place in, then something's wrong. The sequence should be:

Copy .map to \quake\id1\maps
winquake.exe +map ...

So check that first off.

Secondly, your map isn't getting built in the first place because the string containing the .wad files used is too long.

Remove any wads you aren't using in this map from Worldcraft's list of textures before working on this file. If that doesn't work, stick them someplace else, like C:\WADS. 
Steeriiikeee One! 
Thank you so much for the reply. I tried you advice about removing the wad. Strangely enough after doing so and restarting Worldcraft they reappear in the list again??? Messing around some more I did the following:

I deleted all of the desktop icons, and files and folders from the zip-folder. Next I installed the Worldcraft shareware version which deposited itself in �Program Files.� Next I unzipped the Full version of Worldcraft into the Wordcraft-Shareware folder under Program Files supplanting any duplicate files. I then made a test map and got the following result:

The file C:\QUAKE\ID1\maps\ could not be built Do you want to continue?

So I click yes and Quake begins to start and the last message is �Three Demo(s) in Loop� and then Quake does not load.

Here is the information appearing in a Process window:

** Executing...
** Command: Copy File
** Parameters: "C:\QUAKE\ID1\maps\" "c:\quake\id1\maps\"

** Executing...
** Command: C:\Program Files\WorldCraft\Q1Tools\QBSP.EXE
** Parameters: c:\quake\id1\maps\test014

outputfile: c:\quake\id1\maps\test014.bsp
************ ERROR ************
Token too large on line 3

** Executing...
** Command: C:\Program Files\WorldCraft\Q1Tools\LIGHT.EXE
** Parameters: c:\quake\id1\maps\test014

----- LightFaces ----
************ ERROR ************
Error opening c:\quake\id1\maps\test014.bsp: No such file or directory

** Executing...
** Command: C:\Program Files\WorldCraft\Q1Tools\Vis.exe
** Parameters: c:\quake\id1\maps\test014

---- vis ----
************ ERROR ************
Error opening c:\quake\id1\maps\test014.bsp: No such file or directory

** Executing...
** Command: Change Directory
** Parameters: c:\quake

** Executing...
** Command: c:\quake\winquake.exe
** Parameters: +map test014

Can anyone offer some help with this problem and get me back on track with my map making hobby?

I am most grateful

I don�t know if this helps but here is my Worldcraft Build configuration:

Game: c:\quake\winquake.exe
Lighting Program: C:\Program Files\WorldCraft\Q1Tools\QBSP.EXE
Vis Program: C:\Program Files\WorldCraft\Q1Tools\Vis.exe
Place compiled maps in this directory before running the game: c:\quake\id1\maps

Here is my Worldcraft Game Configuration:

Game Data Files: C:\Program Files\WorldCraft\Quake.fgd
Texture Format: WAD2(Quake, Hexen 1)
Map Type: Quake
Default entry Point Class: info_player_start
Game Directory: c:\quake
RMF Directory: c:\quake\id1\maps
Palette file: C:\Program Files\WorldCraft\quake.pal

Well now that I have made these changes I am not sure if I took a step forward or backward? At least now Quake begins to start, but there are still errors that prevent progress.

My thanks to anyone who can help more. 
For Future Reference: 
this question would be better asked in the "mapping help" thread. It doesn't need its own discussion thread.

Hmm, maybe i should make a little swastika icon for 'thread nazi' posts. 
Are You Using Quote Marks In The Map Name? 
If so, that could be breaking QBSP.

I know from experience: you cannot use quote marks (") in any value anywhere in a map. 
As well as what metl pointed out (the fact the you posted in both places was extra annoying BTW);

you don't have to install shareware WC before the full version... 
My apologies to the QMap community for the double entry as it was not my intention to annoy anyone. I was foremost trying to get attention to my problem and simply thought a thread specific to Worlcraft was appropriate. At this point I do not know how to fix this apparent intrusion.

With regard to Fat Controller's response. I am not using " in the file names.

With respect to Nonentity's post. Since I took the approach of installing shareware first since I could not install the full version in the conventional sense. Thought it might help. The act of a desperate man.

Someone please take pity and help me (note sobbing sounds) 
Worldcraft Problem 
Try resetting your game configuration for q1 (verify paths etc). Also, try to run the build exe's outside of Worldcraft (i.e. as shortcuts or in a shell). Sound like the problem is outside of Worldcraft. Invalid arg errors are usually an operating system error. 
Manual Approach 
please please try to think about all the steps. are all the files in the right routes? (this is a case for ANY program but specifically for compilers and all the stuff for q-editing)
have you tried making your own wad? merging them doesnt solve the problem. its the size and quantity of textures. you brobably arent using 90% or the textures so try extracting them with texmex.

as fat con said, do the sequence of compile yourself manually with the dos window if you are comfortable.

try the impossible like changing map names, making a similar one from scratch, i dunno, checking textures on liquids, checking for anything which might lead to an error, get another workin rmf file and edit it (i can give you one if you want)

thats all i can think of for now...sorry 
Switch To Hammer 
For me, learning how to use modern Worldcraft (Hammer & Qonverge) turned out to be much easier than trying to get Worldcraft 1.6 to run properly under XP (I couldn't).

Making the change is intimidating at first, but well worth the minimal effort required. 
Thanks Guys! 
Azazel, Thanks for helping. Forgive my ignorance but I do not understand what you mean by resetting my game configuration for q1 (verify paths etc). Nor do I tried building exe's outside of Worldcraft in dos, but got the same errors.

Thanks daftpunk, I tried all of the things you suggested to no avail.

jsHck, My thanks to you as well. You confirm my base suspicions...XP incompatibility. I understand that you can not make Quake 1 maps with Hammer??? Is this not so? If it can be used can you explain how, or direct me to an appropriate source to learn how? 
have you tried just using radiant. GTKradiant is now very good indeed rather than wrestling with wc. i know, its frustrating but just see it as: ok, cant shag catherine zeta jones. i'll have cathy zed smith. she's just as fine, just not as famous.

besides GTK will have a lot of support in the future. wc may well not (like comparing winxp to dos). you may eventually be able to solve the prob (who knows, if you have a new pc next year, i dunno) but you could always run separate hard drives so you almost have 2 different machines with different Operating system 
just not as famous.

is not gtkr an editor or choice for q3 based games? 
just accept the fact that the analogy made no sense. 
Ok Ok 
sorry sorry. dont have to be so harsh.

what i meant is that a lot of guys seem to hang on to wc for q1 and maybe don't consider gtk which is very much better (in my opinion). forget what i said about famous... 
"ok, cant shag catherine zeta jones. i'll have cathy zed smith. she's just as fine, just not as famous."

WC will have and does have support. Just not for Quake. Valve OWNS it. Remember?

Quake is on its last leg. Sure, the purists will live on as long as they fancy. But staying behind is deterimental to design (if you want to improve past primitives). There's so much more possible now. So, doodle with Quake for as long as you like, but also look into new stuff that, while probably not the same, can suit your tastes. And be open to the possibility of letting those tastes change and adjust (or refine, if you prefer to use that term). 
Clap Clap Clap 
woo hoo. how the hell did you do that?? wish i could do that stuff...

valve own it yeah. but i'm still wondering and asking people what valve are doing atm. they remind me of 3drealms. these guys are like Marty looking at his photo in Back to the future and seeing himself fade...

i mean, are valve working on something or just pretending.

blah. i should just rant less... 
* Wazat falls back with a fatal blow to the heart


I'd get into the new engines, but so few interest me. Maybe doom3 will have good coding oportunity. Maybe flying pigs will become my magical servants too. >:p

I've just watched all these new communities spring up rapidly and then crumble because their foundation is built off a pretty engine rather than a real game.

Ok, now that I've thoroughly condemned myself to months of flogging, I'll retire with the comfort that only half the people here know where I live. :)

BTW, I would have modded for UT if I hadn't been too lazy. It is a nice game, IMHO. 
WC 1.6a 
Where can I download it? It's @ The Forge 
Not @ 
just in case that didnt link:

i tried it once, similiar to worldcraft..

i think the download isn't working or is slow? i cant remember - tried weeks ago - but i got WC 1.6 full right now anyway (woot) 
WC 1.6a 
Worldcraft 1.6 Full Version 
is there still even a Quake 1 WC version for sale? If not I think gettin a 'free' copy is justifiable... IMO 
No, I Don't Think So 
But I beleive that the Valve Hammer Editor, (which is basically the latest version of Worldcraft), is available free of charge.

Not to say that makes it right,........ but if you need something to make you feel all warm and fuzzy inside, thats as good an excuse as any. ;) 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.