News | Forum | People | FAQ | Links | Search | Register | Log in
Soul Of Evil: Indian Summer: New Version (Includes New Content)
Today Patrick Martin and I release a new version of Soul Of Evil: Indian Summer, which includes the following:

-A new map, Nsoe6: Summer's End, with 300+ monsters, including previously unused ones such as the Warlock and Gremlins.

-Newly rebalanced gameplay throughout the episode, both maps and monster code, making the fights fairer while remaining challenging.

-Other new features and items including a new version of the legendary Mjolnir, Dragon Armour, and the deadly MIRV.

Download here:
http://www.quaddicted.com/filebase/nsoe2.zip (28 MB)

Screenshots here:
http://www.quaketastic.com/upload/files/screen_shots/nsoe2a.jpg
http://www.quaketastic.com/upload/files/screen_shots/nsoe2b.jpg

We have also released the nsoe devkit, containing documentation and source code, here:

http://www.quaddicted.com/filebase/nsoe_devkit.zip (1MB)

And the sources for my major maps (nsoe3,4,5,6) are now available here:

http://www.quaddicted.com/filebase/nsoe_sources.zip (2MB)
First | Previous | Next | Last
Help Please 
Get this error when loading a savegame using Fitzquake. I beat the first level, then got another similar error upon loading the second level, so I went to load my save game and it doesn't work.

Chamber of Mazarbul

SV_StartSound: archer/arrowr.wav not precacheed
CALL2 215(setmodel)setmodel()
shot.qc : AkArrow_Launch
archer.qc : M_FireAkArrow
archer.qc : archer_fire1
archer.qc : archer_hold
<NO FUNCTION>
no precache: progs/arrow.mdl

Host_Error: Program error
VID_Gamma_Restore: failed on SetDeviceGammaRamp 
Hmmm 
Did you save this game with the older version of the mod, then load it with the newer one? Save games aren't necessarily valid from one version of a mod to the next. AFter re-reading your post I'm no longer so sure it is the cause, but it is possible.

For people with an interest or who make mods, here's why: A save game consists of a text file containing a dump of all of the entities and all of the global variables at the time the game was saved. This isn't a complete record of everything the engine needs to know, importantly for us it does not contain a list of precached sounds and models.

When the engine loads a saved game, the first thing it reads is the map name, and then it spawns the map as if you were starting a new game on it. This should precache all of the sounds and models in the correct order, so it lines up with what the save game expects. It then goes through and repopulates the level with the entities from the save file, thus restoring the state.

When you change the progs.dat between saving and loading, this process can go wrong in a number of ways. You could do something obviously dangerous, like removing the precache of a model which can be seen in the save file.

You could also just shuffle the orders of precaches, if you swapped the precache of a monster with it's projectile, you might notice the models of the monster and projectile also get swapped. This is because the save file stores the .modelindex field as well as the model, and reordering the precaches might change the modelindex corresponding to those models.

On a related note, the game loading code also makes the assumption that the order of precaches is deterministic. If you were to add

if(random() < 0.5)
precache_model ("progs/h_knight.mdl");

to the top of worldspawn then each time you load a save game you'd have a 50% chance of getting all the modelindexes before h_knight.mdl wrong. This may sound like a perverse example, but if you imagine an entity which picks between three corpse models on a random basis when spawned, it's easy to see how it could also arise in practice.

Finally, this problem is not exclusive to revising the progs.dat, you can cause the same problems by creating a new version of the map; if you add a monster, or reorder the ones you have, or change the number of brush-based entities in your map then the same thing can happen. If you're trying to do something like that(although it makes less sense to keep save games compatible with a new map version) you must be sure you haven't changed the order or precaches on all skill settings. 
Hm 
I've played Soul of Evil using Fitzquake before and I played through it fine on nightmare.

I made a whole new folder for Indian Summer called nsoe. Never played the old Indian Summer before. Don't know why this happens, but I'll start a new game and see if it crashes again. 
 
Ok, I beat the first level again on Hard, and it crashes upon loading the second level with this:

CALL1 229(precache_sound)precache_sound()
axeman.qc : axeman_cache
axeman.qc : monster_axeman
hknight.qc : monster_hell_knight
<NO FUNCTION>
PF_precache_sound: overflow
Host_Error: Program error
VID_Gamma_Restore: failed on SetDeviceGammaRamp 
Engine With Higher Than Standard Limits Is Required. 
Having the same limits as standard Quake, FitzQuake cannot run much of nsoe. Most of the nsoe levels will break a limit in some way. 
So To Summarize 
RTFM ;) 
#30 Is Correct... 
based on the previous releases, nsoe2.bsp has excessive sounds, and nsoe3.bsp has excessive clipnodes, signon buffer, sounds, and lightmaps. For these reasons, fitz080 can't load them. 
 
chasm8.bsp
7608 planes 152160
34016 vertexes 408192
13621 nodes 326904
6725 texinfo 269000
26710 faces 534200
32364 clipnodes 258912
8254 leafs 231112
32277 marksurfaces 64554
121753 surfedges 487012
61835 edges 247340
186 models 11904
144 textures 1353760
lightdata 988847
visdata 2049759
entdata 191151

My map is close to a few!! :P

Models, clipnodes, marksurfaces, (entities (!) (for Tyrlite)) and it has 61 lightmaps (64 limit)

Lol!

Sounds like the map (^^^) was on the model limit to me...... 
Nose6 Is A Monster 
It crashed aguiRe's enhanced winquake and nehahra engine for me, when I tried to load a quicksave. 
Aguire's Regular Glquake 
worked fine for me. 
It Can Work Alright, 
but I tried to record a second demo with saved game (my 1st run demo of NSOE6, and I died when going for the third runekey, so I need to record a second demo with savegame), it started ok, then when I tried to quicksave after making some progress, it crashed.


The error message says:
ED_ParseEdict: EOF without closing brace on line 467 
Now It Seems The Two Savegames 
are both fucked up. I can't load them now in aguiRe's glquake, winquake, and nehahra engine.

Just a moment ago I was still able to load it and continue a bit, but now it can't even be loaded! 
 
Nsoe6 + darkplaces killed my linux twice. First crashes i've seen in ages. 
Nose6 Save Bug 
i tried various versions of darkplaces and nose6 itself works fine but save is broken. there are also some brushes near the mjolmir secret area where you can fall through into void... can this be the reason?.... 
OT: 666 Threads Right Now 
here on FUNC_MSGBOARD 
Re: A Few Things 
Re: # 25
You make a good point; after Masque, and four maps on par with it in terms of scale and horde combat, all in a similar style/texture theme of medieval outdoor ruins (except nsoe4, which was fairly different), I can imagine the gameplay getting a bit exhausting even with the constant challenge. Hopefully Arcanum will, at least in places, provide a moodier, more subtle experience. It's the first set of "indoor" maps I've done since SOE E2 - even nsoe4 worked like an outdoor map despite its underground setting.

Re: Bugs
I've had Darkplaces work fine with nsoe6 on all the computers I've tested it on (4 different PCs, different hardware and setups), same with aguirRe's GLQuake. Savegame bugs are probably something to do with the progs rather than the map although I'm no programmer and I could easily be wrong. I'll ask PM.

I apologize for the problems people are experiencing in nsoe6. It's one of my largest maps. I was aware of two clip problems (one by hammer secret, one by chainlightning), but they shouldn't crash the map. My advice is to use aguirRe's GLQuake; Darkplaces is great but it's a picky engine; I could never get it to run nsoe3 except with all brush entities on noclip. Funny that I'd be able to break a limit-breaking engine, but then, only aguirRe's engines are really designed for mappers. I actually had to wait a few years to finish some of these maps until the tools and engines caught up to the scale of stuff I'd built; even now, nsoe3 and 4 were once one map, and after that nsoe4 and 5 were one map. 
Enjoy It 
I enjoyed playing this. Having to deal with the dragons was very intense and I liked how the usual "go hide behind something" was not a useful tactic at all because they were airborne.

Hats off for the huge amount of work the cumulative features of the mod included. I can only imagine.

I never did find the MIRV or the hammer. I did end up being terminally stuck on the map where you first confront Bane. I couldn't kill him, probably because I didn't have a heavy weapon. 
Weapons 
Mjolnir and MIRV Launcher can be found in nsoe2 and nsoe6. Mjolnir is hidden within secrets in both maps. As for the MIRV Launcher, it is near the exit in nsoe2, and near the final rune in nsoe6. 
 
> I've had Darkplaces work fine with nsoe6 on all the
> computers I've tested it on

Yes.. it worked for me. My two crashes might be hardware, though my new system seems solid doing other stuff; Quake 4, compiling kernels, etc. 
Fun Fun 
Crazy fun on nightmare. After completing nsoe6, I started going through the previous NSOE levels again, and found the instructions for the MIRV... Oh well! I love all the levels, even though nsoe5.bsp is one map I will never try to complete a run without saving. 
Arena Mode 
Where�s the arena mode? 
Dm Mod With Frikbots 
 
Re: #46 
If you are asking about dmsp mode, that can be accessed by typing either 'temp1 1' or 'impulse 70' into the console, then restart the level.

Instructions for adding FrikBots is the same as in the SoE 2002 release. 
Thanks 
Thanks! 
Low Framerates 
Hello, I am using Aguirre's engine to run NSOE6. I am getting low framerates in certain areas of this map. Is there anyway to make it run faster, like removing corpses? I am always using r_shadow 0 and r_flatstylelights 1. Thx 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.