News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First | Previous | Next | Last
Was Your Map Fully Vised? 
Normally I test with a fast vis, but one of the first things I tried when I noticed the problem was a level 4 vis, as I thought it could simply be performance. The problem exists with it fully vised. 
For what it's worth, the 0xa005 error code appears to be the audio library reporting that it's run out of memory. So it makes some sort of sense that having a lot of something would cause that error (in this case I would guess it's all the simultaneous sounds from the wall torches and other entities).

BoraxMan, I don't mean that to sound like your map is at fault. From what you've said it sounds like this is an issue that affects FTE but not other engines. I'm unfortunately not familiar enough with the code to be able to say exactly why this is happening. You might need Spike or someone else knowledgeable to weigh in on this.

In the meantime, you could try confirming the problem by testing another map that has a large number of wall torches. One such map is bbin1 which has 198 wall torches (according to a quick grep). As indicated above, I doubt it's wall torches specifically that are the problem (I would guess it's the number of simultaneous sounds), but either way, I suspect that bbin1 might give you the same sound issue? If it does, you'd at least know it's not just your map. 
I run into an error, "No Free Edicts" when trying it. I tried to use -num_edicts 2000 and higher values, but I don't think FTE supports this parameter?

For what its worth, I tried my level on a Windows machine I borrowed, and the problem didn't come up. I use Linux, so perhaps this problem is specific to the Linux client (both 32 bit and 64 bit clients were tested and the error was replicated).

Lastly, I understand that you didn't mean that my map was at fault. It was me that brought up this possibility, because I do have a weird clipping issue on a specific stair I can't get rid of, and Quark reports a few invalid brushes, though I can't seen to find where they are because Trenchbroom and QBSP see no problem. BSPUTIL --check reports some clipnode problems (though I note other maps also have this). It's a guess that perhaps this might be resulting in something screwy, I'm not sure.

I'm going to be putting the level up for Beta testing soon, so perhaps that will be a good opportunity to see if anyone who happens to use this engine also experiences the same.

I have some programming knowledge, so I might have a look through the code see if anything pops out at me. 
From It's Own Thread..... 
Few FTEQW/QuakeC Questions [EDIT]
Posted by 3t0 on 2020/03/25 10:58:25
As I broke my leg very badly in february and as whole city got quarantined due to infection, I was "given" some time to mess with Quakes again. For now I left my Doom "experimentation" on back-burner.

BTW, congratz to Trenchbroom team for releasing QT port, it seems to work awesomely!

Normally I am Quakespasm Spiked user, but recently I got to compile FTEQW (finally found the compile instructions). So far it seems to work rather well, besides one most annoying glitch ever.

What is driving me insane, gameplay wise, is that when I am riding a vertical platform (or a lift) in FTEQW, whole object is "jumping" and stepping along the path like crazy (like in old Half-Life/CS, and I don't play HL/CS anymore, so I am not sure if that one got fixed, but it used to be as horrible as here). In both Quakespasm and QSS, movement of platform under player is silky smooth. Am I missing something, like some cvar or what? Is FTEQW (which seems otherwise incredibly capable) missing platform movement interpolation, or is it something else? This seems to be happening with AD as well as with Copper and vanilla.

After dissecting some mods and doodads from internet, it appears that FTEQW is indeed very powerful. Seems like good basequake to mess with, to try hack together quake-like "games". What I am always interested in most engines is skeletal model format support (due to reasons). FTEQW natively supports awesome Cube2/Sauer's IQM model format which is great. What I would really like to know, is if anybody had some luck in using IQM attachments to bind things together?

Second thing is QuakeC. It seems it moved forward quite lot, especially in FTEQW. From my initial spelunking, it seems that one can finally do "modern" C function prototypes with `funcname(args...)` which I am more used to. Does anybody knows whether FTEQW really has JITs interpreter for QuakeC code? QCJIT conditional in codebase suggests there is support for that, which sounds awesome, but maybe it's just a scaffolding for something unfinished? JIT referencing chunks of code seem rather small.

Finally how can one get hold of this demigod Spike? I guess it would be much saner and polite asking him these stupid questions privately, than to spam this forum.

#1 posted by chedap on 2020/03/26 10:52:05 spam
AFAIK platforms are a framerate/physics issue. Try setting "cl_maxfps 72" in FTE, should behave same as QS. QSS and vkQuake have physics independent from framerate.

Can't help much with IQM/QC.

#2 posted by misc_ftl on 2020/03/26 14:28:35 spam
the only thing that bothers me with FTEQW is the huge amount of unused code everywhere, tons of conditionals like that one you mentioned and, well, just cruft. It feels like a lab experiment. An awesome one, but kind of messy to base your stuff on.

I highly recommend using QSS. It feels leaner and has all the goodies from FTEQW without the cruft.

Another interesting base is this:

i think that's Spike's attempt at a minimal engine 
Is There A Darkplaces Thread Too? 
Just asking.
FTE always was intriguing too me, yet, as mentioned above, always made a very experimental impression.

Thats why i stick with darkplaces. 
For all your webassembly mp needs: 
Weird Fps Drop In Ad_swampy And Sound 
I've been trying out FTE over the last few days.
I stumbled into a weird bug with AD in ad_swampy. Whenever I fire the SSG I get a huge drop in fps for just a few ms. It remains playable but it's not optimal.
I've set the fps counter to show the worst fps and indeed it shows drops from 150fps to 20/25fps when I fire the super shotgun.
I don't have the issue in the start map or in sepulcher, which is super strange to me.

I'm using the spasm graphic preset but I have tried messing around with the settings but nothing fixes it.
I even tried with no audio because I also have another issue where the underwater sound is way too loud.
On a sidenote it seems the audio output device menu is bugged when there are spaces in the device name (the console says the engine tries each part between spaces in turn before reverting to default device)

I have tried versions 5660 and 5529 of FTE.

Any idea what might be causing those problems? 
I don't get the FPS drops. Try with "impulse 130" (hitscan shotguns), would that fix it?

The issue with spaces is specific to OpenAL I think. So is the weird loud underwater reverb. I've found that you can use e.g. "s_device dsound" to set the device from autoexec or console, without the exact device name.

Note also that music is going to sound bad regardless of chosen device, unless the sound frequency matches the one in the music files. FTE defaults to 48khz, commonly shared ogg and mp3 rips are 44.1. Especially obvious in the E1M1 track. 
I have tried with the hitscan shotguns but it gives me the same issue. I've also tried deactivating AD particles (with the temp1 cvar flag), but that does not do anything.
I've tried a minimalist quake install (with only pak0.pak and pak1.pak in id1 and fresh AD 1.70 folder) with the "-nohome" argument. It's a little better, with dips into the 30/40 fps range when I fire the SSG (I also have the issue with the shotgun but to a lesser extent).

Thanks for the snd_device command. It did work with my minimalist install, but does not work with my main quake folder, I don't know why (snd_restart gives me no sound with s_device = "dsound").

I seem to also have the issue BoraxMan mentioned above where the game gets slower at I spend time in a level.

I guess I'll stick to QSS for AD for now.
I still think FTE's a nice engine with cool features for a lambda player like myself. 
I've been trying out FTE over the last period. I like it very much. An engine capable of dealing with huge single player maps and, at the same time, providing access to quakeworld multiplayer network!

However, I've a problem with Rhoenie's built for Mac. MWHEELUP and MWHEELDOWN can be assigned, for example for changing weapons, but they do not work.

The same config works perfectly under windows.

bind mwheelup "impulse 10"
bind mwheeldown "impulse 12"

yes the binds are there. They work under Win but not in OS. This is why I'm reporting! thanks 
Fence Textures In Hexen 2 
Tried func_detail, func_detail_fence, nothing. Both with color index 0 and 255.
Is it even supported at all in Hexen? 
Func_detail Is Ericw Compile Add On 
Func_detail is a compile parm specific for quake compiling. Nother sure if HexenII compiler can use it. 
There is a func_detail and a func_illusionary for HexenII (in Trenchbroom) as well though.
I'll take a look at the source. 
I Think 
I twisted map compiling with code compiling. 
whats the most stable FTE build for 64 bit linux? latest master crashes too much :( 
Vulkan Support 
Hi there! I was drawn to this engine for it's features, ease of use and Vulkan support. Unfortunately, I can't seem to get Vulkan working. When I select it and Apply the change, my screen starts to flicker and the engine eventually crashes.

I'm running Windows 10, v1909 with an AMD Radeon Vega 64 on current drivers - 20.5.1. GL drivers for AMD cards are known to be poor, but Vulkan tends to run with great performance.

I'd love to get Vulkan working if you have any thoughts on recommended settings or tweaks that might help.

Vulkan Support Additional Information 
Just thought I would add if it helps, I have tried builds 5529 and 5695, both 32 and 64 bit versions. I would be happy to take a look at older potentially working builds but I don't see anywhere they can be downloaded from.

Thanks again. 
Vulkan Error 
I find I am getting the following error - ERROR: vkAcquireNextImageKHR: VK_NOT_READY - Perhaps this helps troubleshoot. 
@ Placo 
Regarding the huge FPS drop, yes, this I think is a sound driver issue, add: `snd_device dsound` to you `autoexec.cfg` 
I love FTE but recently I tried using Reshade with it and I can't seem to get it to work. I have FTE and Reshade set to use GL but no luck. Any ideas? 
Just Started Using This Sourceport Because Of AD 1.8 
Some basic questions:
Why my graphics settings doesn't save after quit?
Why crosshair and console text is smooth when everything else from textures to particles can be made crispy pixelated? 
MP3 Music 
Bump alert, sorry in advance.

Was wondering how to get MP3 music working? I used the tracks that play just fine in QSS, put them in a "music" subdir in my id1 folder and then... nothing. Am I missing a DLL or something? Trying with latest build 6051 in Win 10 x64. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.