News | Forum | People | FAQ | Links | Search | Register | Log in
Arcane Dimensions 1.80
AD 1.8 was released yesterday. It's a little buggy but Simon said he plans on a patch today.

Lots of changes and refinements from the last release. The most interesting for me is custom HUD's. Something not really seen in other Quake mods.

UPDATE: new links from sock:


Downloads (v1.80 p1 final):
Sock -
EU (bal) -
Moddb -
First | Previous | Next | Last
Tnx Bal 
Regarding my sound issues, turning down the sound quite a lot actually fixed it. I have to go under 50%, but then the clipping is gone and there seems to be no adverse issues with having it so low either. So thanks for the tip, @bal! 
Replayed Grendel to warm up for checking out some new stuff:

Then jumped into XMASJAM1024_Sepulchre aka AD_AHKALAKAHAKA aka Pulsar's map/room which was pretty cool and packed a lot in:

Both include a lot of derping, a fair amount of getting secrets, appreciation of the designs, and occasional "cuss words". 
Nyarthingy's Castle:

In which Shambler mostly gives up the derping for now and occasionally offers a convincing pretence at competence. 
Bal, you have any plans to re purpose your old nehahra maps into AD maps? Would be ashamed to see the stuff go to waste. 
No not really, Greenwood was kind enough to recycle one of them and release it, but I don't really have the courage to go back to them, rather work on new stuff. 
Bal's Color And Numbers Enigma 
What's that enigma in the super-secret room ? It says

"Could you be an slower? Here have an old pot as consolation priz",

with a few luminous numbers and color code.

What is this? After searching a lot all around the map, I didn't found a clue. 
#102 @Barnak 
See post #37 
Expect to hear that question in the future despite your answer, I already told him what you said like 3 times. 
Not Being Rude, Just Yelling It Like It Is 
Yhe1 seems to believe that other people are his own personal bitch to do what he wants them to do, and that if asks the same question over and over and over again he'll eventually grind you down into doing what he wants.

I've been on the receiving end of that too. 
Not a demand, just an suggestion 
#103 Thanks... 
But then, I think this panel is very cryptic and may be puzzling to most players. It really feels like some sort of enigma code to solve, a new mystery, almost like in the old Myst game (especially considering the easthetics of that large, island-like map). 
maybe it's part of an ARG 
I've noticed that this installation, in PAK's instead of folders runs better on my PC than old 1.7 version. Is it because of these packages, or because lack of tons of fan maps and props in the folder? Or there took place some optimisation in new version's code? 
I love the look of Bal's new map and what I've played so far has been great, but I'm getting a surprisingly poor framerate in the outdoor sareas. While on the starting pillar I'm getting around 180 fps but if I go to the outdoor area directly behind the start I only get about 40 fps. I'm using vkQuake (also happens with QSS) with an i7 6700HQ, a GTX1070 mobile, and 16GB of 2400KHz RAM. This just seems like extremely low frame rates compared to what I usually get in Quake maps, even the larger ones. Thanks for any help. 
Hello Everyone 
I'm trying to play this in QSS but for some reason QSS only wants to load AD 1.7.1. I downloaded 1.8 from the OP, extracted the zip, copied the contents into my ad folder just like I have for previous AD updates. I open up QSS, type 'game ad', start a new game and when I look in the console, I see '[Info] Arcane Dimensions v1.70 Patch 1'.
The result is the HUD doesn't display properly and although I can load the two news maps, they don't display/run properly. I'm not sure why it's defaulting to 1.7.1, when I'm certain I've installed 1.8.1 properly. I have the latest version of Quakespasm and I installed QSS from the download link in the readme (specifically, I use the 'Win64 dev build'. I'd be very grateful for any help! 
Install AD 1.8 in a different folder, like "ad18" for example (and run with -game ad18) if you want to keep your existing 1.7 version in folder "ad".

The new version must be installed "clean" and "fresh", NOT over the existing 1.71 or whatever version of AD!

Otherwise you have a mess of 1.8 and 1.7 files resulting in problems you're having. 
Thanks! Looks to have solved the problem. 
I got back to Leptis Magna today,but the boss battle steadily crashes on me giving a Packet Overflow error. To be precise, it gave two different errors:
sz_getspace: overflowhost_error: server returned version 100211154, not 15 or 666 or 999
sz_getspace: overflowNd demos listed with startdemos

Initailly I played on Quakespasm 0.93.0, with this command line

C:\QUAKE\quakespasm.exe +sv_protocol999 -heapsize 262144 -game AD

then I noticed that the console said unknown command "protocol999"

I took the Sv_protocol999 command and the game says

"running protocol999"
unknown command "r_useportalculling"
unknown command "cl_beams_polygons"
unknown command "max"

then I installed 0.93.2 and it's the same. Game crashed with the first error message.

Can someone point me in the right direction?
Keep in mind that I played almost all of AD 1.8 patch 1 before Leptis and everything went smooth as silk. Thanks a lot in advance... 
VkQuake Update 
A new version of vkQuake has just been released that probably fixes problems running AD 1.8 (haven't tested it myself yet). 
Sock Releases AD 1.8 Test Maps 
Collection of 60+ test maps for #ArcaneDimensions 1.8 aimed at level designers who want to know how the new features work. Be warned this is blockout visuals and uncluttered setups. 
Not much help but I've done the boss battle with AD 1.8 - once with vKQuake and once with QuakeSpasm Spiked - without issues.

You shouldn't have to add the heapsize command with QuakeSpasm as it has 256 MB as default IIRC, but doubt that is the issue.

BTW, thanks for the tip on the new version of vKQuake @Berzerk2k2, I'll try it. 
Uh... Thanks... 
...I played Leptis countless times without issues. I still have the previous version of AD, I'll try it and see what happens.

The heapsize is my default command line and I just copied/pasted, I'm not that savvy about this kinda things.

And why two different error messages? 
@the Silent 
You could try it without the heapsize command line and see if it helps. It did for me a couple of years with another map, which was when I realized I didn't have to use it with QuakeSpasm.

But, as said, doubt it is the issue in this case as it's basically the same heapsize as you get as the default. 
Leptis Packet Overflow 
I tried to reproduce this. I have latest (non-Spiked) QuakeSpasm and fresh install of AD 1.8p1, went into Leptis Magna, used notarget and noclip, god, impulse 9 and went into the boss arena.

After I triggered the boss, somewhere in the middle of the boss battle I guess there was just too much stuff around? The game started printing "Packet overflow!" and then crashed into console but without any error messages. (Just tried it again, this time QS crashed into Windows).

It it too much particles created by the boss and golems? I noticed in regular quake and other mods that when there's too much monsters around, especially in the 'horde combat' maps, two things happened - sounds started to cut out and/or disappear, and same for particles, i.e. no rocket trails, no blood drips, no particles for Scrag or Death Knight projectiles as well, and also Packet overflow messages could appear. Is there any way around that?

Maybe something to add to command line or quake.rc? I never used -heapsize, etc... 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2023 John Fitzgibbons. All posts are copyright their respective authors.