News | Forum | People | FAQ | Links | Search | Register | Log in
R U B I C O N R U M B L E P A C K
Is complete. It features maps by myself, MFX and Hrimfaxi. It's based off Rubicon2 and includes a few new enemies and features.

Download links: quaddicted / dropbox

Here's the link to the required engine (quakespasm svn r980):
http://celephais.net/board/view_thread.php?id=60452&start=1108
I'm sure more engines will support this pack with time.

UPDATE 1: Devkit is now available here

UPDATE 2: Patch (bsp + lit): https://www.dropbox.com/s/2lk84vnzy3oeaeo/rrp_patch103.zip?dl=0

Full Patched Download: https://www.dropbox.com/s/5xzckbmk99yz8mp/rrp_v103.zip?dl=0

Fixed Bugs:
HOMS through walkways at odd angles
Zfighting inside door frames
Unmarked / broken secrets
Crash on easy skill
Items falling out of level

New Stuff:
Added coop starts (untested)
Added dirtmapping
Added brushes to better divide the visleafs (performance)
Added some dynamic helper signs to aid navigation
Various miscellaneous tweaks and gameplay fixes
First | Previous | Next | Last
Sweet 
Ready to rumble :). Through the door, start map is gorgeous. 
Yep 
MFX knows how to do pipery :) 
Just Looked At The Bsp Sizes 
holy hell! 
FUCK ! 
Dude, I tried this pack on Quakespasm OS X, and there's a huge screen redraw problem, like some walls are getting invisible or something.

It's the first time I see this problem. 
Two Maps Crashed To The Desktop With: 
********************************************
ERROR-OUT BEGIN

Shutting down SDL sound

QUAKE ERROR: Mod_LoadBrushModel: maps/telefragged.bsp has wrong version number (844124994 should be 29)

dano@dano-on-tux:~/quakespasm-0.85.9$
********************************************

From what I've seen it's gonna be awesome once I get the engine prob sorted. 
Are You 
Using the engine listed in the readme?

Nothing else will work! 
Maybe This Needs To Be Changed In The Readme 
" ...the preferred one is Quakespasm (august 29th prerelease) 0.85.10"

Should note instead that it's mandatory. 
And Sorry 
Barnak, you're the first to test on Mac... 
Engine 
In theory certain others will work, but they're untested and most likely missing features like fence textures.

The error above is an engine that does not support BSP2, so will not load the main maps at all.

Others support it and may work, but most probably don't have enough limits raised to support the level requirements properly. 
Heh? 
I did test it on Macs.
No problems there for me. 
^^thasme 
 
FSAA 
Ok, I've found the source of my problem : FSAA (from the latest QS).

Removing FSAA solves the issue (but WTF !?).

The first map I played was awesome. Need to find the other map entrances... 
 
Yeah, here's the link to the required engine again (quakespasm svn r980):
http://celephais.net/board/view_thread.php?id=60452&start=1108
I'm sure more engines will support this pack with time.

Barnak, thanks for the bug report. that's weird fsaa would cause issues, but glad you got it working.

For linux users, here's a suggested command to build the engine from source:

sudo apt-get install libsdl1.2-dev gcc subversion build-essential libvorbis-dev libmad0-dev libogg-dev
svn co svn://svn.code.sf.net/p/quakespasm/code/trunk/quakespasm@980 quakespasm-r980
cd quakespasm-r980/Quake
make

Sorry it's a bit inconvenient, ideally there would be a stable Quakespasm 0.85.10 release already, but the timing didn't work out.

--

So excited this is out, and going to play it tonight! 
Congratulations Guys 
Looking forward to playing it, though probably won't get a chance to for a LONG time.
What I have seen, forever ago, was already very very impressive! You should all be super fucking proud. 
 
This defaults to the pixelated mode. Can there be an option to use filtering. Thanks 
Gl_texturemode 6 
delete quake.rc from the pak if putting the above in autoexec.cfg doesnt work. 
 
Yeah I personally know how to change it, but not everybody does 
Yep 
I have never liked the practice either. 
Hm 
Maybe I should have been more conservative with forcing such things on the player.

But with that frame of mind the pack would never have been made in the first place.

The fence textures not being filtered is worth it.

And that's as close to an apology I'll get for adding the rc file. 
Hmm... 
Filzip doesn't think this is a valid zip file. What zip opening program do i need for this? 
7-Zip Can Open It 
 
 
tried 7-zip too (9.20 which is the latest stable version) ... says it's not valid. 
 
It's bad enough how sock always forces his settings onto the users, there's absolutely no need to follow his example. This one even changes the resolution for no reason. Fuck it!

Is this compressed with 7zip using the "ultimate" compression preset for zip by any chance? Should always only use "maximum" for compatibility. 
 
okay, false alarm, the zip format opens fine in filzip now. I just had to re-download it a couple of times. Maybe the download got corrupted. 
Metl 
maybe re-download? I've unzipped it with 7-zip 9.20, the "unzip" command-line tool, and the OS X built-in unzip utility.
The zip I have is 85,407,483 bytes. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.